6
CREATING TABLES AND VIEWING DATA

6.1 INTRODUCTION
The database is a concept of file organization. It consists of related files stored together so that groups of data items can be easily retrieved. Visual FoxPro also consists of related files organized in such a way that the user accesses groups of data easily. In Visual FoxPro the data and information is stored in the form of Table. More than one table can be created in a single Visual FoxPro database with different group of data items. Visual FoxPro allows the data to be stored, maintained, manipulated and retrieved.

6.2 OBJECTIVES
After going through this lesson you will be able to

• create a table with table Wizard
• create a table with table designer
• open an existing table
• append, edit and delete records in the table
• index and sort data
6.3 CREATING TABLE WITH TABLE WIZARD

There are two ways of creating a Table using:

(i) Table Wizard

(ii) Table Designer

The Table Wizard allows you to create new tables based on any of the group of typical standard tables that are in-built with Visual FoxPro. The Table Wizard is a useful shortcut, which helps you in creating your own table. For many applications, you need to create a new table from the scratch, which becomes more easier using Wizard. In this section, we will concentrate on creating table with Table Wizard.

To create a new table by using Table Wizard, do the following:

Choose **New...** option from the **File** menu. Create a new database for a specific application so that all the related components pertaining to the application can be stored in that database. The **New** dialog box for creating a fresh Table is shown in Fig. 6.1.

![Fig. 6.1: Dialog Box for creating new components](image-url)
Select the **Table** radio button, and then choose **Wizard**. The Table Wizard dialog box appears as shown in Fig. 6.2.

![Table Wizard](image)

**Fig. 6.2: step 1 of the Table Wizard dialog box**

The Table Wizard dialog box displays a list of in-built available standard tables designed to store related data Payments, Products, projects, Reservations, Students and many other types of tables as shown in the figure 6.2. You can select any one of the table according to your requirement from the sample Table lists. For example **Students** Table is considered as example in rest of the lessons.

### 6.3.1 Selecting Table Fields

The fields available with the selected table will be displayed in the **Available Fields** list. You can select the fields to include in your new table by using the Field Picker to move them from the Available Fields list to the Selected Fields list as shown in the Fig. 6.3
Select the required field from the Available Fields list and then click the \( \text{push} \) push button to add the selected field into the Selected Fields list. You can also move the required field from the Available Fields list to the Selected Fields list by simply double clicking in it.

To add all the fields from the Available Fields to Selected Fields list, click \( \text{Push} \) Push button.

Select the field from the Selected Fields list and then click \( \text{push} \) push button to remove it back from the Selected Fields list to the Available Fields list.

To remove all the fields from the Selected Fields list back to Available Fields list, click \( \text{push} \) push button.
To change the order of an existing field to a different location in the table, click the double-headed arrow $\uparrow \downarrow$ to the left of the field you want to move and drag the field to a new location.

You can also move an existing field by using the Keyboard. Press $<$Tab$>$ Key until the desired field is selected, then hold down the $<$Ctrl$>$ key and then press the Up and Down arrow key to drag the field to its new location.

Click Next button, once you are through with the selecting table and table fields. In this case we selected the Student Table and its available fields

### 6.3.2 Selecting a Database

The step 1a of the Table Wizard dialog box as shown in Fig. 6.4 allows you to select a database in which you wish to add your new table. You can create the Database as a stand alone free table. You can also change the name of the table from what was available in the Table Wizard from Student to School.

If a database is open you may add your new table in the existing database.
6.3.3 Modifying Table Fields Settings

After selecting the required table and the table fields from the Table Wizard step 1 dialog box, you click Next push button and then the step 2 of Table Wizard dialog box appears as shown in Fig. 6.5, which allows you to modify the field settings.

![Step 2 of Table Wizard Dialog Box](image)

This dialog box allows you to change the Field Name, Caption, Type and other attributes of the field, according to your requirement. To modify a field, select it and specify the settings you want.

6.3.4 Indexing Table Field

An Index is an arrangement of displaying records in a certain order of the datafield so that records can be accessed very fast. The step 3 of the Table Wizard dialog box as shown in figure 6.6 allows you to select fields that you have included to be used as the basis of an index, which can be used to determine the order in which the table’s records are displayed.

If a database is open, you may select one field on the primary index
key. A primary index key contains a value that is used to uniquely identify each record.

You can also select the check boxes to create other indexes.

- To create an index tag for the table based on that field, which lets you control the order in which the records are displayed, click the check box to the left of the field name. An up arrow occurs, indicating an index in ascending order.

- Click the check box button again, if you want the index in descending order.

- To remove an index tag for a selected field, click the check box to the left of the field until the button is blank.

- To create a primary key with multiple fields select more than one field.

### Fig. 6.6: Step 3 of the Table Wizard dialog box

#### 6.4 SAVING TABLE

Click **Next** push button, after creating an index tag for your table.
The step 4 of the Table Wizard dialog box as shown in the Fig. 6.7 allows you to save the table for later use; save table and browse it; save table and modify it in the Table Designer.

Choose **Finish** push button. The **Save As** dialog box appears as shown in the figure 6.8. You need to specify the directory where the new file will be stored and give a file name by typing a file name in the Name Text box and choose **Save** push button. Be sure that Save As type should be same as shown in figure 6.8.
INTEXT QUESTIONS

1. What do you understand by Indexing?

2. In the Step 1 of creating a table with Table Wizard, you select
   (a) Table and Fields  (b) Table and Records
   (c) Fields and Records  (d) All the above

3. Primary Index Key in a table is always
   (a) many  (b) unique  (c) double  (d) null

4. True or False
   (a) You can create a table only with Table Wizard.
   (b) You can change the field settings in a table created with Table Wizard.

6.5 CREATING A TABLE WITH TABLE DESIGNER

To create a new table from scratch, by using Table Designer. Choose New… option from the File menu. The New dialog box appears as shown in the figure 6.9. Select the Table button and then choose New File. The Create dialog box appears as shown in the figure 6.9. This table is identical to the Save As dialog box and is used in the same way to specify the directory and name of the table.

You can also invoke the Create dialog box by typing the command CREATE in the command window and then press <Enter> key.

For example, in this lesson, we will create a sample student details Table and name it STUDENT and it will be stored automatically with the extension DBF i.e. STUDENT.DBF (Figure 6.9)
Click the Save button, an empty Table Designer dialog box appears as shown in the figure 6.10.
You can also invoke the empty Table Designer dialog box directly by typing the command `CREATE <table name>` in the command window and then press `<Enter>` key as shown in the figure 6.11

![Invoke Table Designer](image)

**Fig. 6.11: Invoking Table Designer**

### 6.5.1 Defining Table Fields

To define each field in the table using the Table Designer dialog box, you should follow these steps:

1. Type a field name (which can be up to 10 characters long in a text) below the name heading. You must note that spaces are not allowed in the field name. The only punctuation allowed is the underscores.

2. Open the **Type** popup and choose one of the data type from the list by clicking on it. The following data types are available on the Type popup.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Character</strong></td>
<td>The character fields can be used to store letters, numbers, special symbols, and blank spaces. The maximum field width of a character field is 254. The default width is 10.</td>
</tr>
<tr>
<td><strong>Currency</strong></td>
<td>The currency fields can be used to store money values. It holds amount from over 900 trillion to less than -900 trillion. The default width of currency data is 8.</td>
</tr>
<tr>
<td><strong>Numeric</strong></td>
<td>The numeric fields can be used to store numbers on which calculation can be performed. The maximum field width of a numeric field is 20 including an optional +/- sign and decimal place. The default width of numeric data is 8.</td>
</tr>
</tbody>
</table>
**Float**

The float field is specifically designed for scientific data. There is no difference between the numeric and float data types. The maximum field width of a float field is 20 including an optional +/- sign and decimal place. The default width of float data is 8.

**Date**

The date fields are used to store dates. The field width of a date type field is always 8. The default date entry and display format is mm/dd/yy. This can be modified to other country formats by using the SET command.

**DateTime**

The DateTime data type can store either a date such as 09/23/02, a time such as 06:35:45 AM, or a date and time such as 09/23/02 06:35:45 AM. The field width of a DateTime type field is always 14.

**Double**

The double data type stores numeric data, but it does calculations with more accuracy than the Numeric data type.

**Logical**

The logical fields accept only single character representing True/False values. Logical True (.T.) can be entered as T, t, Y, or y (yes) and Logical False can be entered as F, f, N, n (no).

**Memo**

The memo fields may be used to store any printable ASCII character (letters, number, blank spaces or special symbols). All memo fields in a database file are stored in a database memo file with extension .dbt which is created while setting up the database file. Memo fields are indicated in the database (.dbf) file by the word memo. Memo field’s sizes are limited by the amount of memory available. Each memo field occupies only 10 spaces in the table.

**General**

The general fields are used to store OLE (Object Linking and Embedding) objects. A width of 10 characters is automatically assigned. The general field’s sizes are also limited by the amount of memory available.

**Character (Binary)**

The Visual FoxPro’s Binary Character data may
include any 8 bit value, including the null character. The maximum field width of a binary character field is 254.

**Memo (Binary)**

The Visual FoxPro’s Binary Memo fields can be used to hold types of data that could never before be manipulated with database management programs, such as scanned images or digitized sound.

3. If the data type you have chosen has a variable field width, a spinner occurs under the heading **Width**. You can change the default value by entering a width in the **Width** text box or by clicking the spinner control.

4. For numeric, double or float data type, you have to specify a value under the heading **Dec** for the number of decimal places the field should have. You can enter the number by typing in the text box or by using the spinner control.

5. The **Null** column determines whether you can enter a **NULL** value in a field.

Based on these details you can create your own table structure named “SCHOOL” by typing the following fields in the Table Designer dialog box as shown in the figure 6.12.

<table>
<thead>
<tr>
<th>Field</th>
<th>Name</th>
<th>Type</th>
<th>Width</th>
<th>Dec</th>
<th>Nulls</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ENROL</td>
<td>Character</td>
<td>9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>NAME</td>
<td>Character</td>
<td>25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>FNAME</td>
<td>Character</td>
<td>25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>COURSE</td>
<td>Character</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>ADD1</td>
<td>Character</td>
<td>25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>ADD2</td>
<td>Character</td>
<td>25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>ADD3</td>
<td>Character</td>
<td>25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>PIN</td>
<td>Numeric</td>
<td>6</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
After defining all the fields in a table structure dialog box, choose OK button. Visual FoxPro displays a dialog box asking whether you want to “Input data records now?” as shown in the figure 6.12.

Choose No, if you don’t want to input data now. Choose Yes to open a Browse window for the table in Append mode, so you can right away begin entering data into the table.

6.5.2 Inserting Table Field

To insert a new field in an existing table in the Table Designer dialog box, position the cursor in an existing field and choose the Insert push button. A new field appears with the name NEWFIELD with a character type and a default width of 10 characters is added before the selected field. Modify these as per your requirement.
6.5.3 Deleting Table Field

To remove an existing field from the Table Designer dialog box, position the cursor to that field and choose the Delete push button. The selected field is deleted and the fields below the deleted field move up one position in the Table Designer dialog box.

6.6 OPENING A TABLE

Once you have created a table, you can open it at any time by using any one of the following techniques:

- Type **Use <table name>** in the command window and press <Return> key. The name of the table, which you have specified with the USE command, is displayed at the left of the status bar. The following command will open the table STUDENT already created.

  Use STUDENT

- Choose **Open** option from the **File** menu. Select the directory and name of the table and choose OK. The name of the table is displayed at the left of the status bar. The status bar also indicates that it has no records, and that it is opened exclusively, so it is not accessible to other user on a network.

6.7 APPENDING RECORDS / DATA

After opening the existing table named “STUDENT”, you can append records in the table by using any one of the following techniques:

- Choose **Append Mode** option from View menu. A new blank record is added to end of the table to enter the data in the table named “STUDENT”.

- Type **append** in the command window and press <Return> key. A new blank record is added to end of the table to enter the data in the table named “STUDENT”. The figure 6.14 shows the example of how to enter data in the Append mode.
Now you can enter the following records, by typing it into each field and pressing <Return> to move to the next field:

<table>
<thead>
<tr>
<th>Field</th>
<th>Values</th>
<th>Field</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENROL</td>
<td>270823001</td>
<td>ENROL</td>
<td>270823002</td>
</tr>
<tr>
<td>NAME</td>
<td>NEELAM NAGPAL</td>
<td>NAME</td>
<td>KISHORE KUMAR</td>
</tr>
<tr>
<td>FNAME</td>
<td>DEEPAK NAGPAL</td>
<td>FNAME</td>
<td>PANKAJ KUMAR</td>
</tr>
<tr>
<td>COURSE</td>
<td>2</td>
<td>COURSE</td>
<td>2</td>
</tr>
<tr>
<td>ADD1</td>
<td>35, LANE NO. 8</td>
<td>ADD1</td>
<td>185-A, POCKET -I</td>
</tr>
<tr>
<td>ADD2</td>
<td>KAILASH COLONY</td>
<td>ADD2</td>
<td>DILSHAD GARDEN</td>
</tr>
<tr>
<td>ADD3</td>
<td>NEW DELHI</td>
<td>ADD3</td>
<td>NEW DELHI</td>
</tr>
<tr>
<td>PIN</td>
<td>110048</td>
<td>PIN</td>
<td>110095</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ENROL</td>
<td>270823003</td>
<td>ENROL</td>
<td>270823004</td>
</tr>
<tr>
<td>NAME</td>
<td>SAROJ KHAN</td>
<td>NAME</td>
<td>MUKEISH KUMAR</td>
</tr>
<tr>
<td>FNAME</td>
<td>MOHAMMAD KHAN</td>
<td>FNAME</td>
<td>PANKAJ KUMAR</td>
</tr>
<tr>
<td>COURSE</td>
<td>2</td>
<td>COURSE</td>
<td>2</td>
</tr>
<tr>
<td>ADD1</td>
<td>35, LANE NO. 10</td>
<td>ADD1</td>
<td>18-A, POCKET -D</td>
</tr>
<tr>
<td>ADD2</td>
<td>SHAHADARA</td>
<td>ADD2</td>
<td>MAYUR VIHAR</td>
</tr>
<tr>
<td>ADD3</td>
<td>NEW DELHI</td>
<td>ADD3</td>
<td>NEW DELHI</td>
</tr>
<tr>
<td>PIN</td>
<td>110032</td>
<td>PIN</td>
<td>110093</td>
</tr>
<tr>
<td>ENROL</td>
<td>270823005</td>
<td>ENROL</td>
<td>270823006</td>
</tr>
<tr>
<td>-------</td>
<td>-----------</td>
<td>-------</td>
<td>-----------</td>
</tr>
<tr>
<td>NAME</td>
<td>POONAM BANSAL</td>
<td>NAME</td>
<td>NARENDRA GOYAL</td>
</tr>
<tr>
<td>FNAME</td>
<td>RAKESH BANSAL</td>
<td>FNAME</td>
<td>PRAKASH GOYAL</td>
</tr>
<tr>
<td>COURSE</td>
<td>3</td>
<td>COURSE</td>
<td>3</td>
</tr>
<tr>
<td>ADD1</td>
<td>123-B, POCKET - P</td>
<td>ADD1</td>
<td>416/7 SECTOR - 19</td>
</tr>
<tr>
<td>ADD2</td>
<td>MALVIYA NAGAR</td>
<td>ADD2</td>
<td>VASUNDHARA ENCLAVE</td>
</tr>
<tr>
<td>ADD3</td>
<td>NEW DELHI</td>
<td>ADD3</td>
<td>NEW DELHI</td>
</tr>
<tr>
<td>PIN</td>
<td>110045</td>
<td>PIN</td>
<td>110096</td>
</tr>
</tbody>
</table>

After you enter the records, you can save the table with the entered data by pressing `<Ctrl> + W` or `<Ctrl> + <End>` key.

**INTEXT QUESTIONS**

5. Write True or False for the following statements.
   (a) The general fields are used to store objects
   (b) The field name in a Table can have space also.
   (c) You can not Insert or delete a field in a Table.
   (d) The Logical fields accept only single character.

6. The maximum length of a field name can be of
   (a) 8chr  (b) 10chr  (c) 15chr  (d) 20chr

7. The maximum field width of a Character field is
   (a) 32  (b) 64  (c) 128  (d) 254

8. Write steps for inserting a column ‘Date-of-Birth’ in Students Table

**6.8 EDITING RECORDS / DATA**

To change or edit data in the table, you need to first open the table by using any one of the techniques mentioned above at section 6.6. After that, choose Browse STUDENT from the view menu to display the data. You can also invoke the edit mode by typing `edit` in the command window. A Browse window in Edit mode occurs to edit the data, as shown in the figure 6.15. Remember that the Browse window in the edit mode allows you only to edit data.
6.8.1 Moving to the specific record

If you are having a large number of records in a table, then it will take a long time to scroll. Visual FoxPro provides you a couple of shortcuts to move through the table more quickly.

Choose Go to Record option from the Table menu to display the submenu as shown in the figure 6.16. The option available with the Go to Records options are described as follows:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Top</strong></td>
<td>Allows you to move to the first record of the table</td>
</tr>
<tr>
<td><strong>Bottom</strong></td>
<td>Allows you to move to the last record of the table</td>
</tr>
<tr>
<td><strong>Next</strong></td>
<td>Allows you to move to the record next to the current record. It is affected by the active index.</td>
</tr>
<tr>
<td><strong>Previous</strong></td>
<td>Allows you to move to the record preceding the current record. It is affected by the active index.</td>
</tr>
<tr>
<td><strong>Record #</strong></td>
<td>Allows you to bring up the Go to Record box, as shown in the figure 6.16(a). You can either type</td>
</tr>
</tbody>
</table>
the record number or use the spin controller and then choose **Go to** push button.

**Locate...**

Allows you to bring up the Expression builder dialog box to define the Locate Record for expression.

---

**6.8.2 Finding a Specific Text String**

It is very difficult to find a specific text string, if you are having a large number of records in a table. Visual FoxPro provides you a shortcut to find a specific text string more quickly in your table.

Choose **Find...** option from the **Edit** menu, Visual FoxPro displays
the **Find** dialog box as shown in Fig. 6.17. For example, enter the data “BANSAL” you are searching for in the **Look For** text box. Click the **Find Next** push button from the find dialog box. If the first value you find is not the one you required, continue this process until you get the required one. Then click **Cancel** push button to close the **Find** dialog box.

Click the **Replace** push button from the **Find** dialog box to enter a value that will replace the found value.

### 6.8.3 Deleting Record

To delete a record just click the deletion mark box as shown in figure 6.17 or choose **Toggle Deletion Mark** option from the **Table** menu. Alternatively, you can press <Ctrl> + T to put the mark of deletion at the current record.

A filled in deletion mark indicates that the record will be purged during the next **PACK** command or if you choose **Remove Deleted Records** option from the **Table** menu. Repeat the toggle command to undelete a record.
Remember that once you use **PACK** command on a table, those records marked for deletion cannot be retrieved and is physically removed from the hard disk.

### 6.9 INDEXING DATA

A separate index file specifies the logical order of the records in a table. Records are displayed and accessed in the order specified by the controlling index expression in the index file. There are two types of index files in Visual FoxPro:

1. **Compound Index File**
2. **Single-Entry Index File**

#### 6.9.1 Compound Index File

The compound index file contains multiple index entries or tags. You can have as many indexes or tags as you require depending upon the available disk space. When the file is opened, all indexes in a compound index file are available. The name of the compound index file is same as the table name with the extension **.CDX**

#### 6.9.2 Single-Entry Index File

The single entry index file contains a single entry. You must open this index file and make it active for it to be updated with a table.

For example you can type the following in the command window:

```
Use student
Index on enrol to student
Use student index student
```

A table can have a number of single-entry index files. The name of the compound index file is same as the table name with the extension **.IDX**

#### 6.9.3 Creating Indexes

To create index for STUDENT.DBF, go back to the Table Designer dialog box and click the index tab to switch to the index definition page as shown in the figure 6.19.
The index definition began with the tag **Name** on the left, followed by the index **Type**, the tag **Expression** and a **Filter**. To enter a new tag, enter the name for the tag in the Name column. The name should describe the index. If your index is based on a single field, it is generally easiest to give it a name that is same as the field name. The arrows to the left of the names indicate whether the index is in ascending (up arrow) or descending (down arrow) order. To change the direction select the row and click the button that appears beneath the arrow. In the beginning, you accept the default index type, which is Regular. You can also make Expressions and use Filters while defining indexes.

### 6.10 DEFINING ORDER IN A TABLE

The records cannot be entered in a sorted order as you do not receive the data in sorted order. So you have to enter the records in a random order, but you want to view them sorted by one or more fields.

You can use the **SORT** command to reorder the records in a table. **SORT** takes an existing table and creates a new table sorted by a field or a combination of fields. For example,

```
USE STUDENT
SORT ON NAME TO STUNAME <Ascending/Descending>
```
Creates a new table named “STUNAME” sorted by the student name. Normally you do not use the SORT command as it takes more disk space by creating new table. Indexes provides you a more effective way to view and retrieve data from a table in an orderly manner. Because a table can have more than one index, you can define different indexes for different views or reports.

6.11 WHAT YOU HAVE LEARNT

In this lesson you have learned about how to create a table by using Table Wizard and Table Designer. We also discussed about modifying the structure of an existing table in terms of field’s name, its type and width. You also learned how to create an Index in a table and sort a data table.

6.12 TERMINAL QUESTIONS

1. Differenciate between Sort and Index?
2. Write the Syntax for Indexing a Table.
3. What do you understand by compound indexing?
4. Explain Null Values.
5. How to add Primary Index to a table field?
6. Write steps for Inserting a new record, editing an existing record and moving to a particular record using the table Students.

6.13 KEY TO INTEXT QUESTIONS

1. An Indexing is an arrangement of the value to search a data value fast.
2. (a)
3. (b)
4. (a) F
   (b) F
5. (a) T   (b) F   (c) F   (d) T
6. (b)
7. (d)
8. Open the Table ‘Students’. In View menu, choose Table Designer. Type filed name as ‘Date-of-Birth’ and Type as Character and Width 8.