Developing Website Using Tools

7.1 INTRODUCTION

A number of Software Packages are available in market for creating a website. Among popular softwares are Dreamweaver, Microsoft FrontPage and Flash. These tools provide very efficient and systemic approach for scheduling, creating and managing websites. The web master need not to write html code for positioning of each item on website. The available softwares for web design and development generate the code automatically. We shall discuss FrontPage in detail so that after reading this Course, a Student will be able to create a Website of his/her own using FrontPage.

7.2 OBJECTIVES

After going through this lesson, you would be able to:

- create a website using Microsoft FrontPage software
- explain Hyperlinks to connect frames
- manipulate graphics while designing Web Page
- describe dreamweaver tool is used to create simple web sites
7.3 MICROSOFT FRONTPAGE 2000

It is a member of Microsoft family of Products and shares many features of Microsoft Word, Microsoft Excel, Clipart etc. It manages hyperlinks created in MS-Office documents. It is an integrated platform for development and maintenance of Websites. It does not require a prior knowledge of HTML. We shall be discussing its features in detail.

7.3.1 Starting Microsoft FrontPage

Invoke the Microsoft FrontPage 2000 from Windows as

Start → Programs → Microsoft FrontPage

![Fig : 7.1](image1.png)  ![Fig : 7.2](image2.png)

The opening window in FrontPage will be displayed as above:

7.3.2 Building Website

Before creating a website, a web needs to be created where all the files related to website created can be stored. One can create a Web Site with single Page. But if there is more than one page then start your Web Site by creating the web and adding all related pages within the web. For creating a new web:

File → New → Web
1. In **Websites**, select any one option of your choice to create your new web site. On selecting each option, a brief description is displayed on the right.

2. In the **specify location** text box of the new web, type a name for new web with full pathname or select the web from the existing web created on your computer. When FrontPage 2000 is installed, a default folder **My Webs** is created in **My Documents** folder in which FrontPage can locate all web site’s files. For convenience here, almost all the files related to web site are stored in C:\web2.

   ➢ As a user, you can choose to locate your folder on your hard disk drive or Microsoft’s Personal Web Server. This can make your Computer function as Web site Server.

3. Click **OK**.

### 7.3.3 Viewing Website

A web site can be viewed through different angles for its better management.
Page View

By default the opening window of FrontPage2000 opens in Page View. Here, a user can create Web Pages and web sites. The default filename new_page_1.htm appears at the beginning of the page. The other available views are Folder View, Reports View, Navigation View, Hyperlink View and Task View are displayed on the left side of opening window of FrontPage. The view selected is used for managing Web and Pages. All Views can be accessed through View Bars. On display, by default is the Folder list, which gives the functionality of Windows Explorer.

The steps mentioned in these topics are performed in FrontPage Page View, unless stated otherwise.

For example,
Hyperlinks View

It displays the status of hyperlinks in the web. For example, see the figure.
7.4 CREATING A WEB PAGE

For creating a new Web Page document, click on

**File → New → Page**

Click on the **General** tab. Select the desired Template. It provides the user a layout of the page design i.e. how to place the text, graphics, hyperlinks, labeling of items etc. on the web page. To see the design of a template, click on any template and see its design in Preview window on the right side of the window. To create a Page in your own style, click on Normal Page. This will create a blank Page where you can add items of your choice. Now click **OK**. The new Page displays.

Suppose you have created a Page using **Normal Page** Template, with default filename as **new page1.htm** after the toolbars. Now you can start typing text. See the Figure below:
The first line you have typed, will be treated as Page Title. You can change the Page Title at the time of saving.

Now you can set the Page Title with another name of your choice. The default filename is also the first line of the page. So you can change this also by typing the name of your choice. You can also give the full pathname along with the webname if you are not
storing it in the current web. Your file will be stored with .htm extension.

- Clicking on HTML will show the HTML code of contents of the Page View.
- Preview provides the appearance of web page on Web site.

Inserting Text and Graphics through Files

- To insert Text, Click anywhere in the Cell and start typing. Through file, type Insert → File
- To insert a Graphic, click mouse at a place where the graphic is to be inserted then click on Insert → Picture → File

![Set Page Title](image)

Fig. 7.10

Saving a web page:

For saving a web page, select File → Save As

Type the filename. The page will be stored in the current web. You can also give the full pathname along with the web name if you are not storing it in the current web. The web page file will be stored with .htm extension.

Save Items added to Web Page

1. If you have added sound/video files, graphics and other objects in the page, then you will be prompted to save them by Confirm Save dialog box to the same location.
2. To save all times without being prompted click on **Yes to All**. If you want to get prompt each time to save individual item, click on **Yes**.

When you are saving a file, observe the **Change** button.

By clicking the Change button, you can change the Title of The Page otherwise it will be saved as the written in the first line of the page.

**Saving a web page opened from outside**

If a web page is opened from an outside page i.e. WWW, then click on **Save As** and type the filename with which you want to save the contents. You can also type the full pathname where you want to save the pages.

**Close a Web Page**

To close the current web page, select **File → Close**

Or

Click Close **X** on the Page Title Bar. If any changes done are not saved then you will be prompted to save your work as shown.

Click **File → Exit** will close the file and FrontPage software.

**Open a Web Site**

Few options for opening a website are:

1. Click on Preview mode at the Task windows bar of FrontPage. The will open the current web site.

2. A website can be opened using a Web Browser like Netscape, Internet Explorer etc. Click the Internet Explorer icon on your windows desktop. At address bar, type the full
pathname of homepage of your website e.g. c:\web2\main.htm

3. To open a web site, first open the Web in which all your website related files are stored.

File → Open → type fill pathname or select the Browse button to choose the location of file. After modifications, save it.
Remember the contents of Home Page are stored in Index.htm file. This is the first file being opened by the browser. It is the default page of html. Whatever name is given to website, it searches for Index.htm first.

INTEXT QUESTION

1. Fill in the blanks:
   (a) The opening window of FrontPage opens in _______ view.
   (b) _______ view displays structure of web like an organizational chart.
   (c) The web pages created are stored in default directory _______.
   (d) _______ , _______ and _______ are three modes on FrontPage window screen.

7.5 THEME

Theme is used to insert pre-designed background and graphic styles in a web page. Theme consists of backgrounds, navigational buttons, fonts and colors. To insert a Theme, Click

1. **Format → Theme**

Fig : 7.14
2. You can apply Theme to All pages or selected pages.

3. Click OK.

For inserting Background images, select only Background picture option in above window.

**Using colors**

Select the object you want to color. Then click on **Highlight Color** icon on toolbar.

### 7.6 HYPERLINKS

Hyperlinks are links to another location in the current document, file, page on the World Wide Web. When users click on a hyperlink, they are transported to another link. Hyperlinks are useful for visit i.e. navigation from one page to another or one site to another site or from one URL (Universal Resource Locator) to another locations. You can surf the site very easily if convenient Hyperlinks are available on it. To insert a Hyperlink, which is to mark it as hyperlink.

1. Select the text or graphic which is to mark it as hyperlink.
2. Insert Hyperlink or type Ctrl + K.

**Fig : 7.15**

- **icon1**-Selects a web page from a website using browser on your computer
- **icon2**-Hyperlinks to a file on computer
- **icon3**-Makes hyperlink to send e-mail mail
- **icon4**-Creates a new page and make links t to the new page
3. Choose the desired option or type the address of webpage in URL or type the full path name of the file to be linked and click OK.

4. Select the Target Frame name (discussed later) where you want to display the contents of Hyperlinked item.

The selected text/ graphic will be underlined and with blue color to indicate a hyperlink.

5. To edit Hyperlink, right click the mouse. Choose Hyperlink Properties. The Edit Hyperlink dialog box is displayed. Repeat steps 1 to 4.

**Example**

Let us discuss Hyperlinks in following figure:

![Fig. 7.16](image)

In above window, Hyperlinks are inserted to the headings About Us, Programmes, Departments and Contact Us. Suppose the text to be appeared on clicking About Us heading is stored in a file c:\web2\about-us.htm. When the heading About Us is hyperlinked by pressing Ctrl+K, in URL type c:\web2\about-us.htm. So the heading About Us is linked with the file c:\web2\about-us.htm
When you open this website in your browser like Netscape or Internet Explorer, the above window will be displayed. Further About-us page shows a hyperlink to the word Hindi. Hence there must be some other page containing the details of Hindi topic. See Hindi is underlined with blue color. When you open the browser, clicking on Hindi will open another page.

**About-us page shows a hyperlink to the word Hindi.**

To create an e-mail link to Contact Us heading:

Select the heading Contact Us and type Ctrl+K. Click on icon-4 as shown in above figure. The Edit Hyperlink Windows is displayed as

---

**Fig. 7.17**

---

**Fig. 7.18**

---

**Fig. 7.19**

---
Testing Hyperlink

To test a hyperlink, place mouse on the hyperlinked text, the mouse pointer will change to hand symbol. Click on it to activate it. If the link is on the local hard disk then file application will launch and the file will be displayed. If the link is on Internet, the default browser will activate and prompt you to connect to Internet.

Linking existing pages from WWW and new Pages

You can link existing pages of website from Internet. For example, if you want to display website of NIOS. Select the word NIOS. Then Insert Hyperlink. In URL, type http://www.nios.org and click OK. See figure below.

A hyperlink is inserted at word NIOS with an underline and a color. When you bring mouse on it, it shows a hand like symbol. To see the results, click on Preview at the task bar and then click on NIOS.

To link New Pages to your website. Select the text/graphic to mark as hyperlink. In hyperlink option, click on icon4 in URL section. This will create a new page. You can type text and insert
graphics here. Now click on to your home page i.e. index page. Click preview mode from task bar and click on the hyperlinked text/graphic to display the contents of newly created page.

**Bookmarks**

Sometimes a User wants to access the required information instead of accessing the long documents containing that information. Hence a Bookmark is created for the selected text (paragraphs) and a name is allotted to this selected text. This Bookmark name is underlined with a dashed line. On previewing in web browser, the underline will not be displayed. To insert the Bookmark,

1. Select the text which is to be book marked. This is the place where user will reach on clicking the bookmark.

2. Click **Insert → Bookmark**. Now click OK.

![Fig. 7.21](image)

**INTEXT QUESTIONS**

2. Fill in the blanks:

   (a) .wav is the extension of _______ files.

   (b) _________ are used to visit pages and other destination to current or other web sites.
(c) Theme is used to _______ pre-designed graphics in webpage..

(d) A ____________ text is underlined with dash.

3. Write True or False for the following:

(a) Graphics can not be hyperlinked.

(b) Navigation view displays the web structure.

(c) Bookmark is used as hyperlink to reach the details of the bookmarked text.

7.7 INSERT IMAGE

Graphics/Images are very important components of web designing. These make the web site more appealing and attractive and provide easy and effective reading. After all, the visual impact remains last long in human’s memory. Let us discuss about Graphic and some operations on them in this section. The graphics files uses extension as .gif, .jpeg, .tiff etc. These can be inserted from web site using web browser or from your computer files.

A. Inserting Graphics in Web Page

Option 1  A graphic file can be inserted using Insert → Picture → File

Option 2 Cut and Paste method

- Select any graphic by clicking mouse on it. Press Ctrl Key + C to copy it.
- Place the cursor where you want to insert the graphic. Press Ctrl + V.
- Now right-click the graphic and click on Picture properties. Click on Appearance tab. See the figure.
Developing Website Using Tools :: 181

- Select appropriate Alignment style, Border thickness, Width, Height, Horizontal and Vertical spacing.
- Click OK.

_Few more commands_

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert → Picture → From File...</td>
<td>Insert a picture file</td>
</tr>
<tr>
<td>Insert Horizontal line</td>
<td>Inserts a horizontal line on webpage. Clicking Right mouse on line allows options for setting size and alignment of line</td>
</tr>
<tr>
<td>Insert → File → Clip Art</td>
<td>Inserts the selected picture from Clip Art Gallery</td>
</tr>
</tbody>
</table>

Fig. 7.22

Option 3  Inserting a background Image

To insert a background image,

- Click **Format → Background**
- Select **Background picture** check box. Click on **Browse**

Now select a Background file from your computer or give a
Link address on WWW.

or

On selecting the check box Get information from Another page and clicking Browse allows to select a file from current web only.

- To display the image as watermark, click the Watermark check box.
- Select any Background Color from the drop down box.
- Click Browse to select the picture. You can select the picture from your local hard disk, Clip Art, WWW etc.
- Click OK.

**Try out**

In format→background, type any sound file name from \\
\windows\media\*.wav, and give no. of loops as 20. Now Preview the home page/index file. A background sound will play.

**B. Formatting Graphics**

Graphics needs to be formatted and placed according to the
requirement and limitations of space on your web page. Few methods of positioning graphic are:

(1) **Picture Toolbar**

The Picture Toolbar a set of tools required for editing and making fine adjustments to graphics. It is very useful while working with Graphics. Place mouse on each of these icons to see their purpose. **View** → **Toolbars** → **Pictures** will display it on screen.

![Fig. 7.25](image1)

For example, to Rotate the picture on left, click on picture and click on **Rotate Left** icon on Picture toolbar.

(2) **Sizing graphic using Mouse**

- Select the graphic.

  ![Fig. 7.26](image2)

  ![Fig. 7.27](image3)

  - Click on handles of the graphic to shape it in the required size.
  - Select an option from various Wrapping styles of text around graphics.
  - Click **Format** → **Position**
  - Select any **Wrapping style** option
  - Select a **Positioning Style** option
(4) **Adding Text to Graphics**

Select the graphic to which the text to be added.

- Click **Text** with symbol as A icon on picture toolbar.
- A text box with blinking insertion point appears in the middle of the graphic. Click inside the box and start typing Text. See figure.
- You can drag the text box to accommodate the text.

(5) **Cropping Graphics**

This is most commonly used activity while working with graphics. The graphics you import from clip art or any other file needs to be adjusted on your web page. Cropping means cutting the graphic from top, left, right and bottom so that it can fit at an appropriate place on the web page. To crop a graphic,

- Click the graphic. You will see the handles around four corners of the picture. Also, the picture toolbar will appear on the screen.
- Suppose you want to crop this picture from right. Click the Crop tool from toolbar. The cursor will change like crop tool symbol. Place this symbol on the right handle of the graphic and drag it towards left to crop the graphic from right side.
Like this you can crop the graphic from all corners by dragging the handles with crop tool cursor.

![Fig. 7.30](image)

### Some Short cuts for Formatting Text

<table>
<thead>
<tr>
<th>Commands</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select text. Format</td>
<td>Selects text. Selected text displays in reverse video.</td>
</tr>
<tr>
<td>Paragraph. Choose Left, Right, Center</td>
<td></td>
</tr>
<tr>
<td>Edit → Cut</td>
<td>Deletes the selected text</td>
</tr>
<tr>
<td>Edit → Copy</td>
<td>Copies the selected text</td>
</tr>
<tr>
<td>Edit → Paste</td>
<td>Pastes the deleted/copied text at cursor point</td>
</tr>
<tr>
<td>Insert → File</td>
<td>Inserts a file at cursor point</td>
</tr>
<tr>
<td>Edit → Undo</td>
<td>Restores last operation back</td>
</tr>
</tbody>
</table>
7.8 WORKING WITH TABLES

A Table is used to arrange the information in rows and columns. It is also used to add text, graphics and numeric data.

**Draw a Table**

From Toolbar, click on Draw table icon. Place mouse on Number of rows/columns to include on your table. A Table will be displayed on the screen.

Or

Select Table → Insert

Type number of Rows and Columns. The Rows/Columns can be added/deleted.
Or

Table operations can be performed from tables Toolbar. To view Tables toolbar, click

**View → Toolbars → Table**

![Fig. 7.32](image)

![Fig. 7.33](image)

The Pencil icon on above toolbar allows to draw a Table. Click on each of the icon to see its function.

1. Use the Pencil icon and, holding the left mouse button, drag down in right direction to create a one-cell table. Now release the mouse. This will complete one-cell table.
2. Click mouse on **Draw Table** icon in the Table toolbar to deselect it.

**Table Operations**

Be sure that the cells are selected before giving the following commands:
### Table Properties

To change the appearance of the Table, you can set the Table properties by right clicking the mouse anywhere on the Table.

**Fig. 7.34**

### Cell Properties

To change the appearance of the Cell, you can set the Cell properties by right clicking the mouse anywhere on the Table/Cell.

**Fig. 7.35**
7.8.2 Import Data into Table from Excel

Suppose you have an Excel file (.xls) and you want to bring this data into a Table in web page. To do so:

- Create a Table on web page.
- Select the Table.
- Now Insert → File. Type the Excel filename. The data will appear in rows/columns.

**Command Action**

<table>
<thead>
<tr>
<th>Command Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert → Component</td>
<td>Inserts Spread Sheets, Charts in web page</td>
</tr>
<tr>
<td>Table → Convert → Text to Table</td>
<td>Converts Text into a Table</td>
</tr>
<tr>
<td>Table → Convert → Table to Text</td>
<td>Converts Table data into a Text format</td>
</tr>
</tbody>
</table>

**INTEXT QUESTIONS**

4. Fill in the blanks:

   (a) ________ controls on Picture toolbar is used to change the appearance of the graphics.

   (b) The extra portion of a graphics can be removed using ________ tool.

   (c) A Table is a collection of ______ and ________.

   (d) ________ combines two or more cells in a Table.

5. Write True or False for the following:

   (a) You can resize the graphic by dragging it with mouse.

   (b) Graphics can’t be inserted in Tables.
(c) Gif and jpeg are extensions of a graphic file.

(d) You can wrap Text around Graphics on a web page.

7.9 FRAMES

Frames allow to display more than one pages at a time. A Frame Page is a Web Page consisting of pages that display in their own frame. It divides the browser window into areas to be used for different purposes. For example, main document, content page, page banner etc. which can be used to present different information in different areas. In general when you open a web site, you might have seen one frame on the left containing hyperlinks from where a visitor can access other information. Also you have noticed another frame on the right containing the detailed information about the link on the left side. You might have observed the Logos, Banners, Ads on the top of the website. These are also put in a separate frame. A web designer can arrange the information in a desired way.

Creating a new Frame Page

1. Choose File → New → Page

2. Click on Frames Pages tab.

3. Select the required Frame Page style and click OK.

Fig : 7.36
It will be opened in Normal View. Click on each Frame Style and see its description and design in Preview window on the right. If you select **Banner and Contents Frame** page, the screen Displayed as:

![Image of frame settings]

**Fig : 7.37**

**Setting Pages to display in Frames**

In displaying the pages under frames,

- **Set Initial Page...** button allows to select a file from your local hard disk and web page from web site. You can also type link address in URL text box.

- **New Page** button creates a new blank page. You can type text/graphics or any other contents here.

To save the contents of each frame in a separate file, each Frame can be saved with different name. For example, top, bottom, left and right frames can be saved with different name as tframe.htm, bframe.htm and rframe.htm respectively. Save. Give a filename. These files will be stored in your current web.

- Click each of the frame file separately and see its contents.
Frame Types

When a hyperlink is pressed, the information related to it is displayed. A user can decide where this information is to be displayed. There are basically two types of frames:

1. Parent Frame
   It displays the information in the same frame as the frame of hyperlink item i.e. in the home page frame.

2. Target Frame
   It is a frame where the information of the hyperlink item is displayed in a frame other than the parent frame.
Commands to remember

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>drag the boundary of frames</td>
<td>change the size of Frames by in upward/downward and left/right directions</td>
</tr>
<tr>
<td>using mouse</td>
<td></td>
</tr>
<tr>
<td>Frame $\rightarrow$ Split Frame $\rightarrow$ Split into Rows</td>
<td>splits the frame into 2 rows</td>
</tr>
<tr>
<td>Frame $\rightarrow$ Split Frame $\rightarrow$ Split into Columns</td>
<td>splits the frame into 2 columns</td>
</tr>
<tr>
<td>Frame $\rightarrow$ Delete</td>
<td>deletes a frame</td>
</tr>
</tbody>
</table>

See the splitting of frames into columns.

Fig : 7.39

Frame Properties

You can define your own frame settings in the frame properties dialog box as shown below:

1. **Frame $\rightarrow$ Frame Properties**
2. Type the frame name in **Name** box.
3. In **Initial page** box, type **URL** or click **Browse** to

Fig : 7.40
change the first page displayed in the browser.

4. Select the **Frame size** in **Width** and **Row Height** boxes.
   
   Relative : relative to other frames in same column
   
   Percent  : percent of size of window in a web browser
   
   Pixels    : select the appropriate number

5. Select the appropriate **Width** and **Height** range in **Margins**.

6. Select **Resizable in Browser** so that on browsing, visitors site can resize the selected frame.

7. Under **Show Scrollbars**, choose any one of the (i) If needed (2) Never (3) Always depending upon the usage.

8. In **Frame Pages**, select the required settings.

9. Click **OK**.

### 7.10 CREATING FORMS

A Form is a collection of fields for gathering information. The visitors on web site can fill the entries in the Form. After filling the complete entries in the Form, the visitors have to click the **Submit** button to save the details. The data will be stored in server depending upon the handler used. Forms are added to web site for applying more controls.

#### 7.10.1 Creating a Forms using Form Wizard

In this section, we will discuss how to create a sample Form on web page to capture information.

The form will include only those options which are pre-designed in the software. To begin with,
Choose, **File → New Page → General → Form page Wizard**

![Form page Wizard](image)

1. Click **Next** button
2. Click **Add** button

Fig: 7.41

Select say **contact information** Click **Next** button

![Form page Wizard](image)

Click **Next**

You can change the name of the variable

Click **Next**

Fig: 7.43
To add more information, click **Next** → **Add**

Click on **save results to a text file**.

You can add the filename to store the results of the Form in it.

(default is **forms1t.txt**)  

![Fig. 7.44](image)

**Then Next → Finish**

The default form is displayed as

![Fig. 7.45](image)

You can change the headings in the text box by selecting the text and typing again.

Now save the Form as **File → Save** Give a filename to it.

Click the **Preview** mode to test it. Type the required information and click on **Submit** button at the bottom of the Form. This will save the information.
Clicking on Reset button erases all the current information given on the form i.e. clear the Form.

*Various Form types in FrontPage are:*

<table>
<thead>
<tr>
<th>Form Types</th>
<th>Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form Handler</td>
<td>sends Form Results (data) to a text file, database or e-mail address</td>
</tr>
<tr>
<td>Discussion Form</td>
<td>It allows user to type their comments on web.</td>
</tr>
<tr>
<td>Search Form</td>
<td>allows visitors to search information on web.</td>
</tr>
<tr>
<td>Multi-user Authoring</td>
<td>allows various users to edit, author the same web simultaneously.</td>
</tr>
<tr>
<td>Remote Authoring and Management</td>
<td>allows web masters to edit and manage a website directly on web.</td>
</tr>
</tbody>
</table>

**Customize a Form**

To customize a Form on web page depending upon the requirement and ease. To create a Form,

1. Click mouse at place where you want to insert the Form. Then **Insert → Form**

2. From following options, choose the desired one
   - **Form** inserts a form with Submit and Reset buttons. If items on page are selected when this command is used, the items are enclosed in form.

*Fig : 7.46*
• **One-Line Text box** accepts information in one line only.

• On inserting a **Scrolling Text box**, a user can scroll down the Information (upward and downward movement of the box using mouse)

• **Check Box** checks the existence of an item(s) from the available list, can be selected more than one.

• **Radio Button** is used to choose one item at a time from the available list.

• **Drop Down Menu** shows a list of available options.

• **Push Button** can be configured to Submit and Reset button.

• **Picture** creates a picture form field at insertion point.

• **Label** makes the label of a form field to click i.e. heading for a Form Field.

**Try out**

To play a sound file using a Button

1. Create button using **Insert → Form → Push Button**

2. Right click it and in Form Field Properties, In Label box, give the heading as ‘Sound’

3. Right click Form → Page Properties → give the location of required file e.g. Sound file with extension as .wav and give a loop of say 20. So the sound file will be played 20 times.
Design a sample Form

The above figure shows a sample form created by using most of the tools of Form.

Click **Insert → Form → Form**

For convenience, press one space before typing each new line i.e. at cursor point and press Enter key at the end of each line but not necessary.

**Steps for creating above Form,**

- Line 1 Type ‘enter name’. Insert → Form → click on One-line Text box
- Line 2 Type ‘enter your query’. Insert → Form → click on Scrolling Text box
• Line 3 Type ‘enter qualification’. Insert \to\ Form \to click on Check Box

• Line 4 Type ‘Gender’. Insert \to\ Form \to click on Radio Button

• Line 5 Type ‘Programme’. Insert \to\ Form \to click on Dropdown box

• Now, to enter Push button, Insert \to Form \to Push Button

• To make it a Submit button, right click Form Field properties and select Submit radio button.

• Similarly, insert another button and choose its properties as Reset button.

**Storing Form Results**

FrontPage generates a confirmation page. Right click on Form and click on Form Properties.

Type filename to store the Results of the Form.

1. To see the Form result, In Folder’s view, click to private folder.

2. The results are stored in form_result.txt file.

Double click to set the exact data.

*You can change the location of file where the results of form can be stored, or to store the results as e-mail. Click Insert \to Form \to Form Properties. Change the location of file name or enter e-mail address as in figure.*

*For any other help click F1 to search in Microsoft FrontPage Help.*
INTEXT QUESTIONS

6. Fill in the blanks:
   (a) Frames can be ________ by dragging mouse over them.
   (b) Submit button is used to collect the information from ________.
   (c) A ________ is used to search text in web documents on web page.

7. Write True or false for the following:
   (a) The main frame displays the information about the link pressed in content frame.
   (b) Frames can’t be splitted.
   (c) A Form can only be created using a Form Wizard.
   (d) A Form handler sends form results to a text file.

7.11 DREAMWEAVER

Dreamweaver 8 is the industry-leading web development tool, enabling users to efficiently design, develop and maintain standards-based websites and applications. It is a product of Macromedia family. With Dreamweaver 8 MX, web developers go from start to finish, creating and maintaining basic websites to advanced applications that support best practices and the latest technologies. Macromedia provides a range of products for multimedia authoring and web development. Site contains extensive documentation and support for all software. The concept of Frames, Tables, Form, Hyperlinks etc is also available in Dreamweaver. The opening windows in Dreamweaver is shown as below:
**Exercise** : A sample web site is created in FrontPage as well as in Dreamweaver to give idea to students in using both the tools.
Creating website using FrontPage

To create above sample website, the steps are:

1. Create a new web as File → New → Web. Save it with name as test in C:

   Now your web directory is c:\test

   It is preferred to create all your web pages and other files in same directory.

2. Choose File → Page → New Frame Pages → Header, Footer and Contents

   This will partition your web page into four partitions. Save this page with name as exercise in c:\test

   Fig. 7.51

   Insert graphic from ClipArt in the Top Frame as Insert Clip Art

   with mouse. If can’t then copy it in Paint and again copy it in the Top frame.

   If graphic, type text as ‘An Educational Academy, New Delhi, India’

   button in Left Frame. Type four headings

   About Us

   Programmes

   Departments

   Contact Us

   Now Save the contents in left frame with filename as leftframe.htm
5. Type the contents of heading About Us in Notepad/MS-Word or in any editor and store it as about-us.htm file preferably in c:\test

Similarly create programmes.htm, departments.htm and contact-us.htm to store the contents of respective headings in the directory c:\test

6. To create a Hyperlink for heading About Us, click mouse at A and drag it till the entire heading is highlighted. Now choose, Insert → Hyperlink.

In URL, type the path of filename i.e. c:\test\exercise\about-us.htm

In Target Frame, select Parent Frame.

Similarly create hyperlinks for programmes, Departments and Contact Us.

6. Now Click on New Page in Right Frame. A blank screen will appear. Type ‘AEA Welcomes all students’.

7. Click on New Page in Bottom Frame. Type ‘This is a testing site, used by students.’

All above steps were performed in Normal mode. Now to view the website, click in Preview mode at the task bar. Click on hyperlink About Us, the contents of this are displayed on right frame.

Similarly, click on rest of the links.

Also, You can add same or different Themes in different Frames. For example, select Format → Theme → All Pages → Default
(Arcs) adds same background in all frames.

Now select only the bottom frame, select Format → Theme → Selected Pages → Blends adds the desired Theme in bottom frame only.
Developing Website Using Tools

Same exercise in Dreamweaver

Open Dreamweaver as Programs → Dreamweaver → Dreamweaver

1. Create Top Frame, Insert Frames → Top
   Save it with dtop.htm

2. To create Bottom Frame, Insert Frames → Bottom
   Save it with dbottom.htm

3. To create Left Frame, Insert Frames → Left
   Save it with dleft.htm

4. To create Right Frame, Insert Frames → Right
   Save it with dright.htm

Object windows are opened automatically. If not then, click Toolbars → Windows → Properties or Ctrl+F3 key.

5. Click in top frame, Insert → Image → choose the .jif file (e.g. books.gif)
   Be sure that books.gif is already created graphics from Clip
6. In Bottom Frame type ‘This is testing site, used by the students.’

   Save it with dleft.htm

7. Click in right frame. Save it with right.htm

8. In Left frame, type all the headings as

   About Us
   Programmes
   Departments
   Contact Us

9. Create separate files for storing the detailed information for each heading namely about-us.htm, prog.htm, aca.htm

10. Select the heading About Us on left frame. In Link option, choose about-us.htm

   Click on link icon and Target folder just after the Link option.

   Choose Target Frame as mainframe.

   Similarly click Programme heading, choose Link as prog.htm, Target frame as mainframe.

   Similarly click Departments heading, choose Link as
aca..htm, Target frame as mainframe.

For Contact Us, choose Insert → Email link → e-mail address

File → Save All

Type filename for home page as dexercise.htm. This will be your home page.

File → Frameset saves all frames on the webpage

Open a web site in dreamweaver

To open the website in Internet Explorer, select the hard disk drive in which exercise.htm is stored. Then click on exercise.htm

On clicking each of the links on left frame, the following windows will be displayed.

Fig : 7.56

7.12 WHAT YOU HAVE LEARNT

In this lesson you learnt about various web designing tools particularly FrontPage 2000 in detail.

Another tool, Dreamweaver is also discussed in short. Various components of FrontPage and their functions are discussed. The various views available on FrontPage like Page, Navigation, and Hyperlinks will enable you to design your website in a more
professional way. You also learnt how to build web page and web site in detail. Besides that you can import web pages from an already existing web site. You understood the concept of links and navigation.

### 7.13 TERMINAL QUESTIONS

1. What is the difference between a web page and web site?
2. What do you understand by Navigation?
3. How to insert a hyperlink in a web page?
4. Write the purpose of Bookmark.
5. Create a Frame page as Vertical Split type and set Initial and New Page.
6. Write the properties of Frame Page.
7. Write the difference between Scrolling text box and drop-down menu.

### FEEDBACK TO INTEXT QUESTIONS

1. (a) Page view i.e. normal  
   (b) Navigation  
   (c) `\...\...\My Documents\My Webs`  
   (d) Normal, HTML, Preview
2. (a) Sound  (b) hyperlinks  (c) Insert  (d) Bookmark
3. (a) False  (b) True  (c) True
4. (a) Brightness/Contrast  (b) Crop tool  
   (c) Rows, Columns  (d) Merge
5. (a) True  (b) False  (c) True  (d) True
6. (a) resized  (b) Form  (c) Search Form
7. (a) True  (b) False  (c) False  (d) True